Prism - NYC-11 Offline – Incident details
Report an issue
Get updates
Email
Slack
Microsoft Teams
Google Chat
Webhook
RSS
Atom
API
Report an issue
Get updates
All systems operational
NYC-11 Offline
Resolved
Major outage
Started 2 months ago
Lasted 36 minutes
Affected
NYC - New York, US (US-East-2)
Major outage from 8:38 PM to 9:14 PM
NAE-11
Major outage from 8:38 PM to 9:14 PM
Updates
Resolved
March 20, 2026 at 9:14 PM
Resolved
March 20, 2026 at 9:14 PM
This incident has been resolved.
Investigating
March 20, 2026 at 8:38 PM
Investigating
March 20, 2026 at 8:38 PM
We are currently investigating this incident.